Παρασκευή 27 Ιουν 2014

Νέα έκδοση PHP 5.4 στο ΠΣΔ

Το πιο κάτω μήνυμα αφορά μόνο τους χρήστες  οι οποίοι έχουν δικτυακό τόπο στο Πανελλήνιο Σχολικό Δίκτυο (ΠΣΔ)

Αξιότιμες/οι κυρίες/οι, φίλοι εκπαιδευτικοί

Θα θέλαμε να σας ενημερώσουμε ότι στους WebServers του ΠΣΔ λειτουργεί πλέον και η έκδοση 5.4 της PHP (έκδοση 5.4.28). Η έκδοση αυτή της PHP δίνει την δυνατότητα εγκατάστασης, ακόμα και των τελευταίων εκδόσεων δημοφιλών CMS όπως για παράδειγμα Joomla 3.3, Moodle 2.7+ κοκ.

Καθώς στους ιστοτόπους των χρηστών εξακολουθεί να λειτουργεί ως  βασική έκδοση της PHP η 5.3, θα πρέπει προκειμένου να ενεργοποιηθεί η έκδοση 5.4, να δημιουργηθεί στον φάκελο στον οποίο είναι εγκατεστημένο το CMS, το αρχείο .htaccess με το ακόλουθο περιεχόμενο

AddHandler php54 .php

Η ρύθμιση αυτή είναι απαραίτητη για τη λειτουργία ιστοτόπων με CMS Joomla 3.3, με δεδομένο ότι το CMS αυτό απαιτεί PHP έκδοση μεταγενέστερης της PHP 5.3.10.

Επισημαίνουμε ότι για τις ήδη υπάρχουσες ιστοσελίδες χρηστών του ΠΣΔ που εντοπίστηκαν και που εκτελούν την έκδοση 3.3 του Joomla, και οι οποίες λειτουργούν κάτω από την διεύθυνση http://users.sch.gr/<όνομα χρήστη>, έχει οριστεί αυτόματα κατά την αναβάθμιση της PHP η χρήση της έκδοσης 5.4 με ενημέρωση του αρχείου .htaccess.

Υπενθυμίζουμε, όπως σας έχουμε ενημερώσει και σε προηγούμενο μήνυμά μας, ότι τυπικά το ΠΣΔ παύει την υποστήριξη της PHP 5.2.x την 1η Ιουλίου 2014 και οι χρήστες θα πρέπει να έχουν φροντίσει να προσαρμόσουν τους ιστοτόπους τους. Αν αυτό δεν έχει καταστείδυνατό μέχρι τώρα, θα πρέπει να γίνει άμεσα προκειμένου να μην αντιμετωπίσετε διακοπή λειτουργίας του ιστοτόπου σας. Σε κάθε περίπτωση το ΠΣΔ δε μπορεί να δεσμευτεί για διατήρηση της PHP 5.2.x μετά την 1η Οκτωβρίου του 2014.

Τέλος, υπενθυμίζουμε ότι στην ιστοσελίδα http://www.sch.gr/2010-04-07-07-28-46/2010-04-07-09-19-26/2010-07-05-10-37-49/cms μπορείτε να βρείτε σημαντικές οδηγίες για την εγκατάσταση και λειτουργία των διαφόρων CMS στο ΠΣΔ.

Σας ευχαριστούμε που χρησιμοποιείτε τις υπηρεσίες του Πανελληνίου Σχολικού Δικτύου.

Είμαστε στη διάθεση σας για οποιαδήποτε βοήθεια χρειαστείτε.

Με εκτίμηση

ΠΑΝΕΛΛΗΝΙΟ ΣΧΟΛΙΚΟ ΔΙΚΤΥΟ

——————————————————————-

Υπηρεσία Υποστήριξης Χρηστών, http://www.sch.gr/helpdesk

Υπηρεσία Φιλοξενίας Ιστοσελίδων

Τηλέφωνο:  801-11-801-81

e-mail: webhost@sch.gr

Δευτέρα 5 Μάι 2014

Αλλαγή στην ημερομηνία διεξαγωγής της 2ης ημέρα του σεμιναρίου WordPress

Σας ενημερώνουμε ότι η 2η ημέρα του σεμιναρίου με θέμα «Δημιουργία και συντήρηση ιστοτόπου με χρήση WordPress» που διοργανώνει το ΚΕΠΛΗΝΕΤ Λευκάδας θα πραγματοποιηθεί την Τρίτη 6/5/2014 (από 09:00 – 13:30) αντί της Πέμπτης 8/5/2014 όπως είχε αρχικά προγραμματισθεί.

Όσοι εκπαιδευτικοί είναι χειριστές VBI, και εφόσον δεν μπορούν να αντικατασταθούν από τον αναπληρωτή χειριστή, μπορούν να παρακολουθήσουν με την λήξη των δοκιμαστικών εκπομπών.

Παρακαλούνται οι διευθυντές να ενημερώσουν και να διευκολύνουν τους εκπαιδευτικούς για την παρακολούθηση του σεμιναρίου.

Η παρουσίαση της 2ης μέρας είναι διαθέσιμη στο:
http://dide.lef.sch.gr/plinetl/assets/presentations/2014/wordpress-2.pdf

Τρίτη 29 Απρ 2014

Σεμινάριο WordPress την Τετάρτη 30/4 και Πέμπτη 8/5/2014

Το ΚΕΠΛΗΝΕΤ Λευκάδας οργανώνει διήμερο σεμινάριο για δημιουργία ιστοσελίδων με WordPress στο περιβάλλον του ΠΣΔ για τους εκπαιδευτικούς ΠΕ19/20 Πληροφορικής. Το σεμινάριο θα πραγματοποιηθεί την Τετάρτη 30/4/2014 και την Πέμπτη 8/5/2014 (από 09:00 – 13:30) στο εργαστήριο του 1ου Γυμνασίου Λευκάδας.

Η παρουσίαση της 1ης μέρας είναι διαθέσιμη στο:
http://dide.lef.sch.gr/plinetl/assets/presentations/wordpress-1.pdf

Δοκιμαστικό site σε WordPress για το Γυμνάσιο Βασιλικής μπορείτε να δείτε εδώ:
http://users.sch.gr/angelos-ky/gymvasil/

Σάββατο 15 Φεβ 2014

Tutorial Αναβάθμισης joomla από έκδοση 1.5 σε 2.5 από το ΚΕ.ΠΛΗ.ΝΕ.Τ. Δωδεκανήσου

Με αφορμή την πληροφόρηση ότι από τις 14 Ιουνίου δεν θα υποστηρίζεται η έκδοση 1.5 του Joomla το ΚΕ.ΠΛΗ.ΝΕ.Τ. Δωδεκανήσου δημιούργησε ένα video tutorial (screen cast) με τη διαδικασία της αναβάθμισης χρησιμοποιώντας το plugin jUpgrade. Το tutorial είναι διαθέσιμο εδώ: http://keplinet.dod.sch.gr/article/joomla_upgrade

 

Τετάρτη 5 Φεβ 2014

Κατάργηση της έκδοσης PHP 5.2 τον Ιούλιο 2014

Το πιο κάτω μήνυμα αφορά μόνο τους χρήστες  οι οποίοι έχουν δικτυακό τόπο στο Πανελλήνιο Σχολικό Δίκτυο (ΠΣΔ).

Αγαπητοί χρήστες του Πανελληνίου Σχολικού Δικτύου,

Σε συνέχεια του παρακάτω από 18/10/2013 μηνύματός μας, θα θέλαμε να σας ενημερώσουμε ότι από τον Ιούλιο του 2014 θα σταματήσει οριστικά η λειτουργία της έκδοσης PHP 5.2 στους εξυπηρετητές του Πανελληνίου Σχολικού Δικτύου.

Κατά συνέπεια, θα πρέπει μέχρι την ημερομηνία αυτή να φροντίσετε για την αναβάθμιση CMS ή πρόσθετων (component, plugin, module, template) παλιότερης έκδοσης και συμβατών μόνο με την έκδοση PHP 5.2 που λειτουργούν στους ιστοτόπους σας, σε νεότερη έκδοση συμβατή με την έκδοση PHP 5.3. Σε αντίθετη περίπτωση ο ιστότοπος σας δε θα λειτουργεί καθόλου ή θα εμφανίζει σοβαρές δυσλειτουργίες μετά την οριστική κατάργηση της PHP 5.2 .

Σχετικές οδηγίες για την αναβάθμιση του Joomla είναι διαθέσιμες από την επίσημη ιστοσελίδα joomla.org:

Joomla 1.5.x σε 2.5.x: http://docs.joomla.org/J2.5:Migrating_from_Joomla_1.5_to_Joomla_2.5
Joomla 1.5.x σε 3.x : http://docs.joomla.org/How_do_I_upgrade_from_Joomla!_1.5_to_3.x%3F

Σας ευχαριστούμε που χρησιμοποιείτε τις υπηρεσίες του Πανελληνίου Σχολικού Δικτύου.

Είμαστε στη διάθεση σας για οποιαδήποτε βοήθεια χρειαστείτε.

Με εκτίμηση
ΠΑΝΕΛΛΗΝΙΟ ΣΧΟΛΙΚΟ ΔΙΚΤΥΟ
——————————————————————-
Υπηρεσία Υποστήριξης Χρηστών, http://www.sch.gr/helpdesk
Υπηρεσία Φιλοξενίας Ιστοσελίδων
Τηλέφωνο:  801-11-801-81
e-mail: webhost@sch.gr

Κυριακή 20 Οκτ 2013

Ορισμός της έκδοσης PHP 5.3.x ως βασική

Το πιο κάτω μήνυμα αφορά μόνο τους χρήστες  οι οποίοι έχουν δικτυακό τόπο στο Πανελλήνιο Σχολικό Δίκτυο (ΠΣΔ)

Αγαπητοί χρήστες του Πανελληνίου Σχολικού Δικτύου,

Θα θέλαμε να σας ενημερώσουμε ότι, λόγω μη υποστήριξης πλέον της έκδοσης 5.2.x της PHP (http://www.php.net/eol.php), κρίνεται επιτακτική η ανάγκη να οριστεί η έκδοση PHP 5.3.x ως βασική για την υπηρεσία φιλοξενίας ιστοσελίδων. Η αλλαγή αυτή θα εφαρμοστεί από την Πέμπτη 24/10/2013.

Αν στην ιστοσελίδα σας εκτελείται CMS ή πρόσθετο (component, plugin, module, template) παλιότερης έκδοσης, συμβατό μόνο με την έκδοση 5.2.x, μετά την αλλαγή θα υπάρξει δυσλειτουργία του ιστοτόπου σας.

Σε αυτή τη περίπτωση θα πρέπει να προχωρήσετε σε αναβάθμιση του CMS ή του πρόσθετου σε νεότερη έκδοση συμβατή με την έκδοση 5.3.x της PHP.

Εναλλακτικά, μπορείτε να ορίσετε προσωρινά και μέχρι την αναβάθμιση του ιστοτόπου σας, την λειτουργία του με PHP 5.2.x. Για να γίνει αυτό θα πρέπει να δημιουργήσετε στον φάκελο στον οποίο είναι εγκατεστημένο το CMS, το αρχείο .htaccess με το ακόλουθο περιεχόμενο

AddHandler php52 .php

Αν γίνεται ήδη χρήση του αρχείου .htaccess και σ’ αυτό έχει οριστεί η χρήση της έκδοσης 5.3.x της PHP μέσω της εντολής  AddHandler php53 .php, τότε, μετά τον ορισμό της PHP 5.3.x ως βασική έκδοση,  η συγκεκριμένη εντολή μπορεί να αφαιρεθεί.

Σας ευχαριστούμε που χρησιμοποιείτε τις υπηρεσίες του Πανελληνίου Σχολικού Δικτύου.

Είμαστε στη διάθεση σας για οποιαδήποτε βοήθεια χρειαστείτε.

Με εκτίμηση

ΠΑΝΕΛΛΗΝΙΟ ΣΧΟΛΙΚΟ ΔΙΚΤΥΟ

——————————————————————-

Υπηρεσία Υποστήριξης Χρηστών, http://www.sch.gr/helpdesk

Υπηρεσία Φιλοξενίας Ιστοσελίδων

Τηλέφωνο:  801-11-801-81

e-mail: webhost@sch.gr

Ανάγκη αναβάθμισης των Ιστοτόπων με Joomla από 1.5 σε έκδοση 2.5 ή 3

Αγαπητοί χρήστες του Πανελληνίου Σχολικού Δικτύου,

σας ενημερώνουμε ότι, μετά την ολοκλήρωση ανάπτυξης του Joomla έκδοση 1.5 (http://www.joomla.org/announcements/release-news/5419-joomla-1526-released.html) απαιτείται η μεταφορά των ιστοσελίδων της συγκεκριμένης έκδοσης σε σύγχρονη έκδοση του Joomla 2.5 ή 3 (http://www.joomla.org/download.html).

Η ύπαρξη μη ενημερωμένων ιστοσελίδων καθώς και των σχετικών πρόσθετων, οδηγεί σε κενά ασφαλείας που είναι υπεύθυνα για δυσλειτουργίες των ιστοσελίδων σας και κατά συνέπεια των εξυπηρετητών που τις φιλοξενούν.

Υπενθυμίζουμε ότι πριν προχωρήσετε σε οποιαδήποτε ενέργεια αναβάθμισης θα πρέπει να προβείτε σε λήψη αντιγράφων ασφαλείας της ιστοσελίδας σας στο τοπικό σας υπολογιστή. Σχετικές οδηγίες είναι διαθέσιμες στον ακόλουθο σύνδεσμο: http://www.sch.gr/2796-backup.

Στη συνέχεια και αφού ολοκληρωθεί επιτυχώς η λήψη αντιγράφων ασφαλείας, μπορείτε να προχωρήσετε στην αναβάθμιση του Joomla 1.5 στην έκδοση 2.5 ή 3, με σχετικές οδηγίες είναι διαθέσιμες από την επίσημη ιστοσελίδα joomla.org:

Joomla 1.5.x σε 2.5.x: http://docs.joomla.org/J2.5:Migrating_from_Joomla_1.5_to_Joomla_2.5
Joomla 1.5.x σε 3.x : http://docs.joomla.org/How_do_I_upgrade_from_Joomla!_1.5_to_3.x%3F

Σας ευχαριστούμε που χρησιμοποιείτε τις υπηρεσίες του Πανελληνίου Σχολικού Δικτύου.
Είμαστε στη διάθεση σας για οποιαδήποτε βοήθεια χρειαστείτε.

Με εκτίμηση

ΠΑΝΕΛΛΗΝΙΟ ΣΧΟΛΙΚΟ ΔΙΚΤΥΟ

——————————————————————-

Υπηρεσία Υποστήριξης Χρηστών, http://www.sch.gr/helpdesk

Υπηρεσία Φιλοξενίας Ιστοσελίδων

Τηλέφωνο:  801-11-801-81

e-mail: webhost@sch.gr

Δημοσίευση εκδηλώσεων στην πύλη του Πανελλήνιου Σχολικού Δικτύου

Αξιότιμοι κυρίες και κύριοι, φίλοι εκπαιδευτικοί,

Με το μήνυμα μας αυτό θέλουμε να σας υπενθυμίσουμε  τη δυνατότητα δημοσίευσης  εκδηλώσεων των σχολείων και γενικά της εκπαιδευτικής κοινότητας στην πύλη του  Πανελλήνιου Σχολικού Δικτύου http://www.sch.gr

H ανάρτηση μπορεί να γίνει άμεσα από εσάς ως ακολούθως:

  1. Από την πύλη του ΠΣΔ (www.sch.gr) θα συνδεθείτε είτε με τα στοιχεία του επίσημου λογαριασμού του σχολείου σας είτε με τα στοιχεία του προσωπικού σας λογαριασμού.
  2. Στη δεξιά πλευρά, κάτω από το ημερολόγιο των εκδηλώσεων, θα εμφανιστεί η επιλογή “καταχωρήστε εκδήλωση”, η οποία σας επιτρέπει να προχωρήσετε στην καταχώρηση της εκδήλωσής σας.
  3. Στην καταχώρηση δίνεται η δυνατότητα να επιλέξετε τον νομό καθώς και την περιοχή όπου απευθύνεται η εκδήλωση, αν επιθυμείτε να δηλώνεται μια συγκεκριμένη περιοχή/νομός.
  4. Κάθε καταχώρηση θα πρέπει να έχει έναν τίτλο, ενώ στην περιοχή «δραστηριότητα» θα τοποθετήσετε το κείμενο που αφορά την εκδήλωση σας.
  5. Τέλος θα σημειώσετε την ημερομηνία ή ημερομηνίες πραγματοποίησης, την ώρα και πιθανόν αν υπάρχει επανάληψη της εκδήλωσης.
  6. Συνιστούμε την προσοχή σας στην αποφυγή γραμματικών ή γλωσσικών λαθών. Επίσης δεν θα πρέπει ο τίτλος και το κείμενο να είναι  γραμμένα με κεφαλαία γράμματα, παρά μόνο στα σημεία που η γραμματική ορίζει ή αν θέλουμε να τονίσουμε  κάτι το ειδικό σε κάποια φράση.
  7. Η καταχώρηση σας θα προβληθεί στην πύλη του ΠΣΔ μετά τον έλεγχο και την επιβεβαίωση προβολής από τον συντονιστή  της πύλης.

Θεωρούμε τη δυνατότητα αυτή χρήσιμη για την προβολή της δραστηριότητας των σχολείων, των ΠΔΕ, Διευθύνσεων, ΕΚΦΕ, ΚΕΣΥΠ και γενικά της εκπαιδευτικής κοινότητας.

Σας ευχαριστούμε που χρησιμοποιείτε τις υπηρεσίες του Πανελληνίου Σχολικού Δικτύου.
Είμαστε στη διάθεση σας για οποιαδήποτε βοήθεια χρειαστείτε όπως και για τις προτάσεις και  παρατηρήσεις σας.

Με εκτίμηση

Π Α Ν Ε Λ Λ Η Ν Ι Ο   Σ Χ Ο Λ Ι Κ Ο   Δ Ι Κ Τ Υ Ο

————————————————————

Υπηρεσία Υποστήριξης Χρηστών, http://www.sch.gr/helpdesk

Τηλέφωνο  (χρέωση μία αστική μονάδα): 801-11-801-81

Υποβολή αιτημάτων και αναφορών :  http://helpdesk.sch.gr

e-mail:  info@sch.gr

Πέμπτη 14 Φεβ 2013

Φιλοξενία Ιστοσελίδων: PHP έκδοσης 5.3.15, SEF URL και φάκελος auto

Το πιο κάτω μήνυμα αφορά μόνο τους χρήστες
οι οποίοι έχουν δικτυακό τόπο στο Πανελλήνιο Σχολικό Δίκτυο (ΠΣΔ)

Αγαπητοί χρήστες του Πανελληνίου Σχολικού Δικτύου,

Θα θέλαμε να σας ενημερώσουμε ότι στα πλαίσια αναβάθμισης της υπηρεσίας φιλοξενίας ιστοσελίδων το ΠΣΔ προσφέρει τα επόμενα χαρακτηριστικά:

  1. Υποστήριξη PHP 5.3
    Με δεδομένη  την  αυξημένη απαίτηση για εγκατάσταση των τελευταίων εκδόσεων λογισμικών CMS, όπως για παράδειγμα της έκδοσης 3 του Joomla,  προχωρήσαμε στην υποστήριξη  PHP έκδοσης 5.3, και συγκεκριμένα της 5.3.15.
    Η έκδοση αυτή μπορεί να χρησιμοποιηθεί παράλληλα με την προηγούμενη (5.2.12) και η εγκατάσταση δεν επηρεάζει τις υπάρχουσες δυναμικές ιστοσελίδες οι οποίες εξακολουθούν να χρησιμοποιούν την παλιά έκδοση.Για την χρήση της νέας αυτής έκδοσης PHP θα πρέπει στον αντίστοιχο φάκελο της δυναμικής ιστοσελίδας να δημιουργηθεί το αρχείο .htaccess με το ακόλουθο περιεχόμενο:AddHandler php53 .phpΜε την δημιουργία του αρχείου .htaccess μπορείτε να ελέγξετε  και να ορίσετε  την χρήση με της νέας έκδοσης της PHP στην ιστοσελίδα σας.
  2. SEF (Search Engine Friendly URLs)
    Υποστηρίζονται πλέον κανονικά τα SEF (Search Engine Friendly URLs) στα διάφορα CMS, όπως το Joomla, θα πρέπει, εκτός από την ενεργοποίηση του στο ίδιο το CMS, να  υπάρχει το αρχείο .htaccess   με τον  ακόλουθο κώδικα. Το αρχείο αυτό συνήθως διανέμεται μαζί με τα διάφορα CMS.RewriteEngine On
    RewriteBase <φάκελος στον οποίο βρίσκεται το CMS όπως π. χ. /autosch/joomla15>
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule ^(.*) index.phpΣημείωση:Αν το URL path του ισοτόπου σας ή του σημείο που έχει τοποθετηθεί το CMS  δεν είναι  ο ριζικός κατάλογος ( / ) τότε πρέπει στο .htaccess να γίνει αλλαγή στο RewriteBase  από τον ριζικό κατάλογο ( / ) που είναι εξ’ ορισμού, στο URL  path της εφαρμογής

    Για παράδειγμα:

    • Αν  το CMS(π.χ. Joomla) απάντα στο URL:   http://users.sch.gr/georgiou.
      ορίζουμε    RewriteBase   /georgiou
    • Αn το CMS (π.χ. Joomla) απάντα στο URL :   http://users.sch.gr/georgiou /autosch/joomla15
      ορίζουμε   RewriteBase    /georgiou /autosch/joomla15
  3. Φάκελος auto  με  αυτόματη σελίδα ευρετηρίου (autoindex).
    Αν στον ιστότοπο σας δημιουργήσετε ένα φάκελο auto  στον οποίο τοποθετήσετε κάποια αρχεία, για τα αρχεία αυτά θα δημιουργείται αυτόματα ευρετήριο  στην ιστοσελίδα (πίνακας περιεχομένων- autoindex).  Δείτε για παράδειγμα το   http://users.sch.gr/testacht/auto/

Σας ευχαριστούμε που χρησιμοποιείτε τις υπηρεσίες του Πανελληνίου Σχολικού Δικτύου.
Είμαστε στη διάθεση σας για οποιαδήποτε βοήθεια χρειαστείτε.

Με εκτίμηση

ΠΑΝΕΛΛΗΝΙΟ ΣΧΟΛΙΚΟ ΔΙΚΤΥΟ

Υπηρεσία Φιλοξενίας Ιστοσελίδων

——————————————————————-

Υπηρεσία Υποστήριξης Χρηστών, http://www.sch.gr/helpdesk

Tηλέφωνο (χρέωση μία αστική μονάδα): 801-11-801-81

e-mail: webhost@sch.gr

Οδηγίες για Αναβάθμιση στο Joomla component JCE, λόγω κενού ασφαλείας

Αγαπητοί Χρήστες του Πανελληνίου Σχολικού δικτύου,

Θα θέλαμε να σας ενημερώσουμε ότι στο component JCE  εντοπίστηκε ένα κενό ασφαλείας  το οποίο επιτρέπει στους εισβολείς να αποθηκεύσουν στον ιστοχώρο του χρήστη κακόβουλα αρχεία PHP.

Κατόπιν αυτού αποτελεί άμεση ανάγκη η αναβάθμιση του συγκεκριμένου component στην τελευταία έκδοσή του, ειδικά όταν η εγκατεστημένη έκδοση είναι η 1.5 ή οποιαδήποτε πριν την 2.1.1.

Οδηγίες σχετικά με την αναβάθμιση μπορείτε να δείτε στην παρακάτω σελίδα:

Ø   http://www.joomlacontenteditor.net/support/installation/editor

Είμαστε στη διάθεση σας για οποιαδήποτε βοήθεια.

Σας ευχαριστούμε που χρησιμοποιείτε τις υπηρεσίες του Πανελληνίου Σχολικού Δικτύου.

Με εκτίμηση

ΠΑΝΕΛΛΗΝΙΟ ΣΧΟΛΙΚΟ ΔΙΚΤΥΟ

Υπηρεσία Φιλοξενίας Ιστοσελίδων

——————————————————————-

Υπηρεσία Υποστήριξης Χρηστών, http://www.sch.gr/helpdesk

Tηλέφωνο (χρέωση μία αστική μονάδα): 801-11-801-81

e-mail: webhost@sch.gr